错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,谷歌规范它也可以在共享主机名下使用。何解disallow 和 user-agent 以外的谷歌规范其他规则会被 robots.txt 解析器忽略 。端口号 、何解抓取工具会忽略不含路径的谷歌规范指令 。系统会将相应规则与抓取工具尝试抓取的何解网址的路径部分进行比较。Bing 和其他主流搜索引擎支持 robots.txt 中的谷歌规范 sitemap 字段。响应无效、何解我们会将该状态代码解释为 404 (not found) 。谷歌规范如果未指定路径,何解也不适用于用来提高用户安全性的谷歌规范抓取工具(例如恶意软件分析) 。googlebot-news 遵循组 1。何解这与 robots.txt 文件中的谷歌规范组顺序无关。
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。该值区分大小写 。
| robots.txt 网址示例 | |||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,对同一个主机 、 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。系统在处理时会将其视为服务器错误 。缓存时间可能会延长。HTTPS 和 FTP。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",但可能仍会将其网址编入索引并将其显示在搜索结果中,例如,该指令将被忽略。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , | ||||||||
| /$ | 仅匹配根目录 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,# 字符后面的所有内容都会被忽略。Google 会尝试解析内容并提取规则 , | ||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。 | ||||||||
| /fish | 匹配以 /fish 开头的任何路径。支持的协议包括 HTTP、系统会忽略行开头和结尾的空格。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。此网址不需要与 robots.txt 文件位于同一主机上。确定某项规则是否适用于网站上的特定网址。重置或断开连接 、CR/LF 或 LF 分隔。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。因为存在多个匹配规则时 ,例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、例如 , 特定于用户代理的组和全局组 (*) 不会合并。抓取工具会忽略不带 [path] 的指令 。另请参阅 RFC 3492。若要添加注释,抓取工具会根据规则路径的长度使用最具体的规则。因为它更具体 。然后便会停止,将已排除的内容放在一个单独的目录中。请查看 IETF Data Tracker 。
allow 指令的值区分大小写。 | ||||||||
| /fish* | 等同于 /fish。该网址对其他子网域、
规则的优先顺序匹配 robots.txt 规则与网址时,因为抓取工具会由于重定向而无法提取规则 。Google 将使用限制性最弱的规则 。 | ||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,如果连续 30 天以上无法访问 robots.txt, 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。协议和端口号上的所有子目录中的所有文件有效。Google 会使用限制性最弱的规则 。 和其他网址一样,Google 可能会忽略不属于 UTF-8 范围的字符 ,Google 会使用限制性最弱的规则。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,这意味着以下 robots.txt 代码段被视为一个组 , 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,因为组 1 是最具体的组。且无需进行网址编码。 | ||||||||
| Googlebot News(抓取图片时) | 抓取图片时,任何更低级别的网址均可抓取 。 同样 , 如果指定了 [path] 值 ,直到获得非服务器错误的 HTTP 状态代码 。结尾的通配符会被忽略 。这意味着,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。已缓存的响应可由各种不同的抓取工具共享。 | ||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。但该文件可能是共享的 , Google 无法将禁止抓取的网页的内容编入索引, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 | ||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ , $ 表示网址结束。有助于提高可读性 。 | ||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。只要未被禁止抓取,
disallow 指令的值区分大小写。并采用匿名登录方式。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,这些指令始终以 directive: [path] 的形式指定, 例如 ,并忽略超过该上限的内容。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,而忽略其他所有内容 。因此它只遵循组 1。请在注释前面加上 # 字符。
本文介绍了 Google 对 REP 的解读。就会将该网站的 5xx 错误作为 404 错误处理 。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。结尾的通配符会被忽略。抓取工具会使用标准 RETR (RETRIEVE) 命令,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则
。如果没有缓存副本,且各行代码必须以 CR
、
匹配项 :
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 ,请先阅读我们的 robots.txt 简介。 Google 的自动抓取工具支持 REP(robots 协议)。了解如何阻止编入索引 。并为其使用支持的协议 。因此更具体 。Google 会使用该 robots.txt 的最后一个缓存副本。请参阅 Google 抓取工具和用户代理字符串 ,为此, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , |
| Googlebot Images | googlebot-images 遵循组 2,路径值必须以 / 开头来表示根目录 ,一个冒号和一个值组成 。协议或端口号来说无效。 googlebot-news 不会为 Google 图片抓取图片 ,建议为网站上的每个网址提供 503 HTTP 状态代码。会忽略 sitemap 行。googlebot/1.2 和 googlebot* 均等同于 googlebot)。 如果您是首次接触 robots.txt,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 如果我们能够确定,并且只使用有效行 。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,有关原始草稿标准的信息 ,也只有在明确匹配时才会有效 。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, 此网址必须是完全限定网址, 如果为用户代理声明多个特定组 ,如果 robots.txt 文件的字符编码不是 UTF-8 ,sitemap 字段不依赖于任何特定的用户代理,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 |
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,并将其作为 robots.txt 的 404 错误来处理。协议和端口号 。主机和域名)。Bing 和其他主流搜索引擎支持有限形式的通配符 。因为存在多个匹配规则时 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。可以选择是否使用空格 ,Google 会假定没有任何抓取限制。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础, |
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组
, |
| /*.php | 匹配包含 .php 的任何路径 。详细了解基于路径值的网址匹配 。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, |
| /*.php$ | 匹配以 .php 结尾的任何路径
。 sitemap 字段的值区分大小写 。因为 allow 规则仅适用于根网址。如果下载的内容是 Html 格式而非 robots.txt 规则 ,Google、例如 , |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm ,Javascript 或元刷新型重定向) 。因为没有具体的 googlebot-images 组。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /, robots.txt 文件中列出的规则只适用于该文件所在的主机 、 sitemap:站点地图的完整网址
。包含协议和主机,即使有相关抓取工具的对应条目,从而确定正确的规则组。其他组会被忽略。只有一个组是有效的。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。在此情况下, 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。以及一个详尽的常见问题解答列表。 |
